$re = '/[\s\S]*?<div\sid=\"variationsTwister[\s\S]*?>[\s\S]*?<div[\s\S]*?<span[\s\S]*?<span[\s\S]*?>([\s\S]*?)<\/span>/m';
$str = ' <div id="variationsTwister" class="a-section a-spacing-mini">
<div class="a-section a-spacing-micro">
<span class="a-size-base">Size:</span>
<span class="a-size-base a-text-bold">6 M US</span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);