using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\s\S]*?<div\sid=\""variationsTwister[\s\S]*?>[\s\S]*?<div[\s\S]*?<span[\s\S]*?<span[\s\S]*?>([\s\S]*?)<\/span>";
string input = @" <div id=""variationsTwister"" class=""a-section a-spacing-mini"">
<div class=""a-section a-spacing-micro"">
<span class=""a-size-base"">Size:</span>
<span class=""a-size-base a-text-bold"">6 M US</span>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}