#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?(((([0][0-9])|([1][0-3])):(([03][0])|([14][5])))|14:00)"
Local $sString = "00:00" & @CRLF & _
"01:00" & @CRLF & _
"00:15" & @CRLF & _
"00:30" & @CRLF & _
"00:45" & @CRLF & _
"01:30" & @CRLF & _
"04:00" & @CRLF & _
"05:00" & @CRLF & _
"06:30" & @CRLF & _
"10:00" & @CRLF & _
"13:00" & @CRLF & _
"14:00" & @CRLF & _
"13:30" & @CRLF & _
"14:30" & @CRLF & _
"20:00" & @CRLF & _
"24:00" & @CRLF & _
"-14:00" & @CRLF & _
"-13:30" & @CRLF & _
"-10:00" & @CRLF & _
"-09:00" & @CRLF & _
"-00:00" & @CRLF & _
"00:10" & @CRLF & _
"00:20" & @CRLF & _
"00:25:" & @CRLF & _
"00:35"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")