import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(((([0][0-9])|([1][0-3])):(([03][0])|([14][5])))|14:00)";
final String string = "00:00\n"
+ "01:00\n"
+ "00:15\n"
+ "00:30\n"
+ "00:45\n"
+ "01:30\n"
+ "04:00\n"
+ "05:00\n"
+ "06:30\n"
+ "10:00\n"
+ "13:00\n"
+ "14:00\n"
+ "13:30\n"
+ "14:30\n"
+ "20:00\n"
+ "24:00\n"
+ "-14:00\n"
+ "-13:30\n"
+ "-10:00\n"
+ "-09:00\n"
+ "-00:00\n"
+ "00:10\n"
+ "00:20\n"
+ "00:25:\n"
+ "00:35";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}