using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(((([0][0-9])|([1][0-3])):(([03][0])|([14][5])))|14:00)";
string input = @"00:00
01:00
00:15
00:30
00:45
01:30
04:00
05:00
06:30
10:00
13:00
14:00
13:30
14:30
20:00
24:00
-14:00
-13:30
-10:00
-09:00
-00:00
00:10
00:20
00:25:
00:35";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}