use strict;
my $str = '00:00
01:00
00:15
00:30
00:45
01:30
04:00
05:00
06:30
10:00
13:00
14:00
13:30
14:30
20:00
24:00
-14:00
-13:30
-10:00
-09:00
-00:00
00:10
00:20
00:25:
00:35';
my $regex = qr/^-?(((([0][0-9])|([1][0-3])):(([03][0])|([14][5])))|14:00)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}