package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?(((([0][0-9])|([1][0-3])):(([03][0])|([14][5])))|14:00)`)
var str = `00:00
01:00
00:15
00:30
00:45
01:30
04:00
05:00
06:30
10:00
13:00
14:00
13:30
14:30
20:00
24:00
-14:00
-13:30
-10:00
-09:00
-00:00
00:10
00:20
00:25:
00:35`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}