#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*(<tag>.*?azaza.*?<\/tag>)"
Local $sString = "<tag>lolo" & @CRLF & _
"ololo" & @CRLF & _
"lolo</tag>" & @CRLF & _
"<tag>ko" & @CRLF & _
"koko" & @CRLF & _
"ko</tag>" & @CRLF & _
"<tag>zaza" & @CRLF & _
"azaza" & @CRLF & _
"zaza</tag>" & @CRLF & _
"<tag>bom" & @CRLF & _
"terebon" & @CRLF & _
"bombom</tag>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")