re = /.*(<tag>.*?azaza.*?<\/tag>)/
str = '<tag>lolo
ololo
lolo</tag>
<tag>ko
koko
ko</tag>
<tag>zaza
azaza
zaza</tag>
<tag>bom
terebon
bombom</tag>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end