import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(<tag>.*?azaza.*?<\\/tag>)";
final String string = "<tag>lolo\n"
+ "ololo\n"
+ "lolo</tag>\n"
+ "<tag>ko\n"
+ "koko\n"
+ "ko</tag>\n"
+ "<tag>zaza\n"
+ "azaza\n"
+ "zaza</tag>\n"
+ "<tag>bom\n"
+ "terebon\n"
+ "bombom</tag>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}