package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).*(<tag>.*?azaza.*?<\/tag>)`)
var str = `<tag>lolo
ololo
lolo</tag>
<tag>ko
koko
ko</tag>
<tag>zaza
azaza
zaza</tag>
<tag>bom
terebon
bombom</tag>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}