import re
regex = re.compile(r".*(<tag>.*?azaza.*?<\/tag>)", flags=re.DOTALL)
test_str = ("<tag>lolo\n"
"ololo\n"
"lolo</tag>\n"
"<tag>ko\n"
"koko\n"
"ko</tag>\n"
"<tag>zaza\n"
"azaza\n"
"zaza</tag>\n"
"<tag>bom\n"
"terebon\n"
"bombom</tag>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")