const regex = /.*(<tag>.*?azaza.*?<\/tag>)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(<tag>.*?azaza.*?<\\\/tag>)', 's')
const str = `<tag>lolo
ololo
lolo</tag>
<tag>ko
koko
ko</tag>
<tag>zaza
azaza
zaza</tag>
<tag>bom
terebon
bombom</tag>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}