using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(<tag>.*?azaza.*?<\/tag>)";
string input = @"<tag>lolo
ololo
lolo</tag>
<tag>ko
koko
ko</tag>
<tag>zaza
azaza
zaza</tag>
<tag>bom
terebon
bombom</tag>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}