# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\+(\d{2})-(\d{3}(?: \d{3}){2})\b/$1 $2/gm;t' <<< "+61-426 861 479"