using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+(\d{2})-(\d{3}(?: \d{3}){2})\b";
string substitution = @"$1 $2";
string input = @"+61-426 861 479";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}