use strict;
my $str = '+61-426 861 479';
my $regex = qr/\+(\d{2})-(\d{3}(?: \d{3}){2})\b/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";