# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<DisplayContents>[\s\S]*?<Contents>(.*?)<\\/Contents>[\s\S]*?<\\/DisplayContents>/$1/gm;t' <<< "<DisplayContents>
<ID>8</ID>
<Type>102</Type>
<Contents>A whole bunch of stuff in this tag</Contents>
</DisplayContents>
<DisplayContents>
<ID>8</ID>
<Type>102</Type>
<Contents>A whole bunch of stuff in this tag</Contents>
</DisplayContents>"