# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<DisplayContents>[\s\S]*?<Contents>(.*?)<\/Contents>[\s\S]*?<\/DisplayContents>"
test_str = ("<DisplayContents>\n"
" <ID>8</ID>\n"
" <Type>102</Type>\n"
" <Contents>A whole bunch of stuff in this tag</Contents>\n"
"</DisplayContents>\n\n"
"<DisplayContents>\n"
" <ID>8</ID>\n"
" <Type>102</Type>\n"
" <Contents>A whole bunch of stuff in this tag</Contents>\n"
"</DisplayContents>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.