const regex = /<DisplayContents>[\s\S]*?<Contents>(.*?)<\/Contents>[\s\S]*?<\/DisplayContents>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<DisplayContents>[\\s\\S]*?<Contents>(.*?)<\\\/Contents>[\\s\\S]*?<\\\/DisplayContents>', 'gm')
const str = `<DisplayContents>
<ID>8</ID>
<Type>102</Type>
<Contents>A whole bunch of stuff in this tag</Contents>
</DisplayContents>
<DisplayContents>
<ID>8</ID>
<Type>102</Type>
<Contents>A whole bunch of stuff in this tag</Contents>
</DisplayContents>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);