$re = '/<DisplayContents>[\s\S]*?<Contents>(.*?)<\/Contents>[\s\S]*?<\/DisplayContents>/m';
$str = '<DisplayContents>
<ID>8</ID>
<Type>102</Type>
<Contents>A whole bunch of stuff in this tag</Contents>
</DisplayContents>
<DisplayContents>
<ID>8</ID>
<Type>102</Type>
<Contents>A whole bunch of stuff in this tag</Contents>
</DisplayContents>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;