using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<DisplayContents>[\s\S]*?<Contents>(.*?)<\/Contents>[\s\S]*?<\/DisplayContents>";
string substitution = @"$1";
string input = @"<DisplayContents>
<ID>8</ID>
<Type>102</Type>
<Contents>A whole bunch of stuff in this tag</Contents>
</DisplayContents>
<DisplayContents>
<ID>8</ID>
<Type>102</Type>
<Contents>A whole bunch of stuff in this tag</Contents>
</DisplayContents>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}