#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<DisplayContents>[\s\S]*?<Contents>(.*?)<\/Contents>[\s\S]*?<\/DisplayContents>"
Local $sString = "<DisplayContents>" & @CRLF & _
" <ID>8</ID>" & @CRLF & _
" <Type>102</Type>" & @CRLF & _
" <Contents>A whole bunch of stuff in this tag</Contents>" & @CRLF & _
"</DisplayContents>" & @CRLF & _
"" & @CRLF & _
"<DisplayContents>" & @CRLF & _
" <ID>8</ID>" & @CRLF & _
" <Type>102</Type>" & @CRLF & _
" <Contents>A whole bunch of stuff in this tag</Contents>" & @CRLF & _
"</DisplayContents>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)