import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<DisplayContents>[\\s\\S]*?<Contents>(.*?)<\\/Contents>[\\s\\S]*?<\\/DisplayContents>";
final String string = "<DisplayContents>\n"
+ " <ID>8</ID>\n"
+ " <Type>102</Type>\n"
+ " <Contents>A whole bunch of stuff in this tag</Contents>\n"
+ "</DisplayContents>\n\n"
+ "<DisplayContents>\n"
+ " <ID>8</ID>\n"
+ " <Type>102</Type>\n"
+ " <Contents>A whole bunch of stuff in this tag</Contents>\n"
+ "</DisplayContents>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}