#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\\\text\s*\{[^{}]*}"
Local $sString = "\\text { c. } 50 \\times 14" & @CRLF & _
"" & @CRLF & _
"\\left. \\begin{array} { l l } { \\text { b) } 2 \\frac { 1 } { 5 } \\div ( \\frac { 4 } { 5 } - \\frac { 1 } { 4 } ) } & { } \\\\ { \\text { b) } \\frac { 1 } { 4 } - \\frac { 3 } { 4 } ) } & { } \\end{array} \\right."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")