const regex = /\\\\text\s*\{[^{}]*}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\\\\\text\\s*\\{[^{}]*}', 'gm')
const str = `\\\\text { c. } 50 \\\\times 14
\\\\left. \\\\begin{array} { l l } { \\\\text { b) } 2 \\\\frac { 1 } { 5 } \\\\div ( \\\\frac { 4 } { 5 } - \\\\frac { 1 } { 4 } ) } & { } \\\\\\\\ { \\\\text { b) } \\\\frac { 1 } { 4 } - \\\\frac { 3 } { 4 } ) } & { } \\\\end{array} \\\\right.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}