// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\\\text\s*\{[^{}]*}").unwrap();
let string = "\\\\text { c. } 50 \\\\times 14
\\\\left. \\\\begin{array} { l l } { \\\\text { b) } 2 \\\\frac { 1 } { 5 } \\\\div ( \\\\frac { 4 } { 5 } - \\\\frac { 1 } { 4 } ) } & { } \\\\\\\\ { \\\\text { b) } \\\\frac { 1 } { 4 } - \\\\frac { 3 } { 4 } ) } & { } \\\\end{array} \\\\right.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}