re = /\\\\text\s*\{[^{}]*}/m
str = '\\\\text { c. } 50 \\\\times 14
\\\\left. \\\\begin{array} { l l } { \\\\text { b) } 2 \\\\frac { 1 } { 5 } \\\\div ( \\\\frac { 4 } { 5 } - \\\\frac { 1 } { 4 } ) } & { } \\\\\\\\ { \\\\text { b) } \\\\frac { 1 } { 4 } - \\\\frac { 3 } { 4 } ) } & { } \\\\end{array} \\\\right.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end