$re = '/\\\\\\\\text\s*\{[^{}]*}/m';
$str = '\\\\text { c. } 50 \\\\times 14
\\\\left. \\\\begin{array} { l l } { \\\\text { b) } 2 \\\\frac { 1 } { 5 } \\\\div ( \\\\frac { 4 } { 5 } - \\\\frac { 1 } { 4 } ) } & { } \\\\\\\\ { \\\\text { b) } \\\\frac { 1 } { 4 } - \\\\frac { 3 } { 4 } ) } & { } \\\\end{array} \\\\right.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);