use strict;
my $str = '\\\\text { c. } 50 \\\\times 14
\\\\left. \\\\begin{array} { l l } { \\\\text { b) } 2 \\\\frac { 1 } { 5 } \\\\div ( \\\\frac { 4 } { 5 } - \\\\frac { 1 } { 4 } ) } & { } \\\\\\\\ { \\\\text { b) } \\\\frac { 1 } { 4 } - \\\\frac { 3 } { 4 } ) } & { } \\\\end{array} \\\\right.';
my $regex = qr/\\\\text\s*\{[^{}]*}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}