#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<a class="mention" .*?data-user-id="([^"]*)".*>"
Local $sString = "<p><i><a class="mention" data-mention="@test " data-user-id="2" href="https://backend.test/cp/employees/2">@test </a> </i></p>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)