using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a class=""mention"" .*?data-user-id=""([^""]*)"".*>";
string substitution = @"$1";
string input = @"<p><i><a class=""mention"" data-mention=""@test "" data-user-id=""2"" href=""https://backend.test/cp/employees/2"">@test </a> </i></p>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}