const regex = /<a class="mention" .*?data-user-id="([^"]*)".*>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a class="mention" .*?data-user-id="([^"]*)".*>', 'i')
const str = `<p><i><a class="mention" data-mention="@test " data-user-id="2" href="https://backend.test/cp/employees/2">@test </a> </i></p>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);