use strict;
my $str = '<p><i><a class="mention" data-mention="@test " data-user-id="2" href="https://backend.test/cp/employees/2">@test </a> </i></p>';
my $regex = qr/<a class="mention" .*?data-user-id="([^"]*)".*>/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";