// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<a class="mention" .*?data-user-id="([^"]*)".*>"#).unwrap();
let string = "<p><i><a class=\"mention\" data-mention=\"@test \" data-user-id=\"2\" href=\"https://backend.test/cp/employees/2\">@test </a> </i></p>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}