$re = '/<a class="mention" .*?data-user-id="([^"]*)".*>/i';
$str = '<p><i><a class="mention" data-mention="@test " data-user-id="2" href="https://backend.test/cp/employees/2">@test </a> </i></p>';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;