#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\,id::([^}]*?)::]]><\/string2>"
Local $sString = "[...]" & @CRLF & _
"<item1>" & @CRLF & _
" <string1>sometext</string1>" & @CRLF & _
" <string2><![data[text1, text2,id::aR0sddcsb3NoaQ=::]]></string2>" & @CRLF & _
" <string3>sometext</string3>" & @CRLF & _
"<item1>" & @CRLF & _
"" & @CRLF & _
"<item2>" & @CRLF & _
" <string1>sometext</string1>" & @CRLF & _
" <string2><![data[text1, text2,id::furmdjd73ks=::]]></string2>" & @CRLF & _
" <string3>sometext</string3>" & @CRLF & _
"<item2>" & @CRLF & _
"" & @CRLF & _
"<item3>" & @CRLF & _
" <string1>sometext</string1>" & @CRLF & _
" <string2><![data[text1, text2,id::h6eefvndjd73ks=::]]></string2>" & @CRLF & _
" <string3>sometext</string3>" & @CRLF & _
"<item3>" & @CRLF & _
"[...]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")