use strict;
my $str = '[...]
<item1>
<string1>sometext</string1>
<string2><![data[text1, text2,id::aR0sddcsb3NoaQ=::]]></string2>
<string3>sometext</string3>
<item1>
<item2>
<string1>sometext</string1>
<string2><![data[text1, text2,id::furmdjd73ks=::]]></string2>
<string3>sometext</string3>
<item2>
<item3>
<string1>sometext</string1>
<string2><![data[text1, text2,id::h6eefvndjd73ks=::]]></string2>
<string3>sometext</string3>
<item3>
[...]';
my $regex = qr/\,id::([^}]*?)::]]><\/string2>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}