# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\,id::([^}]*?)::]]><\/string2>"
test_str = ("[...]\n"
"<item1>\n"
" <string1>sometext</string1>\n"
" <string2><![data[text1, text2,id::aR0sddcsb3NoaQ=::]]></string2>\n"
" <string3>sometext</string3>\n"
"<item1>\n\n"
"<item2>\n"
" <string1>sometext</string1>\n"
" <string2><![data[text1, text2,id::furmdjd73ks=::]]></string2>\n"
" <string3>sometext</string3>\n"
"<item2>\n\n"
"<item3>\n"
" <string1>sometext</string1>\n"
" <string2><![data[text1, text2,id::h6eefvndjd73ks=::]]></string2>\n"
" <string3>sometext</string3>\n"
"<item3>\n"
"[...]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.