// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\,id::([^}]*?)::]]><\/string2>").unwrap();
let string = "[...]
<item1>
<string1>sometext</string1>
<string2><![data[text1, text2,id::aR0sddcsb3NoaQ=::]]></string2>
<string3>sometext</string3>
<item1>
<item2>
<string1>sometext</string1>
<string2><![data[text1, text2,id::furmdjd73ks=::]]></string2>
<string3>sometext</string3>
<item2>
<item3>
<string1>sometext</string1>
<string2><![data[text1, text2,id::h6eefvndjd73ks=::]]></string2>
<string3>sometext</string3>
<item3>
[...]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}