import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\,id::([^\\}]*?)::]]><\\/string2>";
final String string = "[...]\n"
+ "<item1>\n"
+ " <string1>sometext</string1>\n"
+ " <string2><![data[text1, text2,id::aR0sddcsb3NoaQ=::]]></string2>\n"
+ " <string3>sometext</string3>\n"
+ "<item1>\n\n"
+ "<item2>\n"
+ " <string1>sometext</string1>\n"
+ " <string2><![data[text1, text2,id::furmdjd73ks=::]]></string2>\n"
+ " <string3>sometext</string3>\n"
+ "<item2>\n\n"
+ "<item3>\n"
+ " <string1>sometext</string1>\n"
+ " <string2><![data[text1, text2,id::h6eefvndjd73ks=::]]></string2>\n"
+ " <string3>sometext</string3>\n"
+ "<item3>\n"
+ "[...]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}