package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\,id::([^}]*?)::]]><\/string2>`)
var str = `[...]
<item1>
<string1>sometext</string1>
<string2><![data[text1, text2,id::aR0sddcsb3NoaQ=::]]></string2>
<string3>sometext</string3>
<item1>
<item2>
<string1>sometext</string1>
<string2><![data[text1, text2,id::furmdjd73ks=::]]></string2>
<string3>sometext</string3>
<item2>
<item3>
<string1>sometext</string1>
<string2><![data[text1, text2,id::h6eefvndjd73ks=::]]></string2>
<string3>sometext</string3>
<item3>
[...]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}