const regex = /\,id::([^}]*?)::]]><\/string2>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\,id::([^}]*?)::]]><\\\/string2>', 'gm')
const str = `[...]
<item1>
<string1>sometext</string1>
<string2><![data[text1, text2,id::aR0sddcsb3NoaQ=::]]></string2>
<string3>sometext</string3>
<item1>
<item2>
<string1>sometext</string1>
<string2><![data[text1, text2,id::furmdjd73ks=::]]></string2>
<string3>sometext</string3>
<item2>
<item3>
<string1>sometext</string1>
<string2><![data[text1, text2,id::h6eefvndjd73ks=::]]></string2>
<string3>sometext</string3>
<item3>
[...]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}