# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G|^)\d{1,2}\K\B(?=(?:\d{2})*\d{3}(?!\d))/,/gim;t' <<< "122123123456.764244
122123123"