#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(?:\G|^)\d{1,2}\K\B(?=(?:\d{2})*\d{3}(?!\d))"
Local $sString = "122123123456.764244" & @CRLF & _
"122123123"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)