import Foundation
let pattern = #"(?:\G|^)\d{1,2}\K\B(?=(?:\d{2})*\d{3}(?!\d))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
122123123456.764244
122123123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)