$re = '~(?:\G|^)\d{1,2}\K\B(?=(?:\d{2})*\d{3}(?!\d))~im';
$str = '122123123456.764244
122123123';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;