const regex = new RegExp('(?:\\G|^)\\d{1,2}\\K\\B(?=(?:\\d{2})*\\d{3}(?!\\d))', 'gim')
const str = `122123123456.764244
122123123`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);