using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G|^)\d{1,2}\K\B(?=(?:\d{2})*\d{3}(?!\d))";
string substitution = @",";
string input = @"122123123456.764244
122123123";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}