re = /(?:\G|^)\d{1,2}\K\B(?=(?:\d{2})*\d{3}(?!\d))/im
str = '122123123456.764244
122123123'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result